hg888皇冠手机登录

Linux下./configure错误详解

十月 5th, 2019  |  www.hg888.com

错误: Can’t find X includes. Please check your installation and add the
correct paths!
缘由:未有X的包含文件
解决:安装xlibs-dev即可

错误: Can’t find X includes. Please check your installation and add the
correct paths!
原因:未有X的含有文件
解决:安装xlibs-dev即可

问题:No package ‘libpanelapplet-2.0’ found
解决:sudo apt-get install libpanelappletmm-2.6-dev

错 误:checking for C compiler default output… configure: error: C
compiler cannot create executables 原因: 解决:sudo apt-get install
libc6-dev

错误:./admin/cvs.sh: 585: autoconf: not found
原因:
解决:apt-get install
autoconfwww.hg888.com 1

问题:No package ‘libpanelapplet-2.0’ found

You must have libxml2 >= 2.6.0 development headers installed to
build.
解决:
sudo apt-get install libxml2-dev

难题:eva不弹出输入法 解决:sudo apt-get install scim-qtimm

错误:checking for C compiler default output… configure: error: C
compiler cannot create executables
原因:
解决:sudo apt-get install libc6-dev

错误:heching for gtk-config… no
checking for GTK – version = 1.2.0… no
***www.hg888.com, The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG enviroment variable to the
*** full path to gtk-config.
configure: error: Cannot find GTK: Is gtk-config in path?
解决:sudo apt-get install libgtk1.2-dev

错误:configure: error: C++ preprocessor “/lib/cpp” fails sanity check

www.hg888.com 2

错误:configure: error: C++ preprocessor “/lib/cpp” fails sanity check
缘由:gcc的零件没装全
解决:apt-get install build-essential

解决:sudo apt-get install scim-qtimm

11、难点:eva不弹出输入法
解决:sudo apt-get install scim-qtimm

错误: *** GTK >= 2.4.0 not installed! *** 原因:没装GTK
解决:apt-get build-dep gedit

错误: C compiler cannot create executables
原因:
解决:sudo apt-get gcc libc6-dev

No package ‘libgnomeui-2.0’ found

错误一:
configure: error:

虽然Ubuntu的apt-get很有利,但是众几个人或许喜欢本人通过源代码编写翻译软件,带上特定的参数能够完成团结对软件的必要。可是,编写翻译时平时会出点没非凡,例如包信赖难题。。。。下边是三个包信赖难点及其消除的下结论

错误:in the prefix, you’ve chosen, are no KDE headers installed. This
will fail.
So, check this please and use another prefix!
原因:install a KDE application in a Gnome environment。
解决:which basically means its going to want to install a lot of KDE
specific packages to work. This ‘configure:error’
is due to it expecting you to be running KDE and again refers to some
‘headers’.
sudo apt-get update
sudo apt-get install kdelibs4-dev kdelibs4c2a

错误:checking for C compiler default output… configure: error: C
compiler cannot create executables
解决:sudo apt-get install libc6-dev

6、错误:configure: error: C++ preprocessor “/lib/cpp” fails sanity
check
原因:gcc的机件没装全
解决:apt-get install build-essential

错误: Can’t find X includes. Please check your installation and add the
correct paths! 原因:未有X的隐含文件 解决:安装xlibs-dev就能够

错误: Qt (>= Qt 3.0) (headers and libraries) not found. Please check
your installation!
缘由:查找提供qt的lib&&headers的软件包,并安装之
解决:apt-get install libqt3-headers libqt3-mt-dev

错误: Qt (>= Qt 3.0) (headers and libraries) not found. Please check
your installation!
缘由:查找提供qt的lib&&headers的软件包,并安装之
解决:apt-get install libqt3-headers libqt3-mt-dev

问题:No package ‘gtk+-2.0’ found
No package ‘gtksourceview-1.0’ found
No package ‘libgnomeui-2.0’ found
No package ‘libglade-2.0’ found
No package ‘libgnomeprintui-2.2’ found
解决:sudo apt-get install libgtk2.0-dev libgtksourceview-dev
libgnomeui-dev libglade2-dev libgnomeprint2.2-dev

问题:No package ‘libpanelapplet-2.0’ found 解决:sudo apt-get install
libpanelappletmm-2.6-dev

No package ‘libgnomeprintui-2.2’ found

在配置进度中,config.log文件是很有救助的。大家能够在那当中搜索荒唐的来源,进而寻找应对艺术。

错 误: Qt (>= Qt 3.0) (headers and libraries) not found. Please
check your installation! 原因:查找提供qt的lib&&headers的软件包,并设置之
化解:apt-get install libqt3-headers libqt3-mt-dev

解决:sudo apt-get install libgtk2.0-dev libgtksourceview-dev
libgnomeui-dev libglade2-dev libgnomeprint2.2-dev

13、问题:No package ‘libpanelapplet-2.0’ found
解决:sudo apt-get install libpanelappletmm-2.6-dev

问 题:No package ‘gtk+-2.0’ found No package ‘gtksourceview-1.0’ found
No package ‘libgnomeui-2.0’ found No package ‘libglade-2.0’ found No
package ‘libgnomeprintui-2.2’ found 解决:sudo apt-get install
libgtk2.0-dev libgtksourceview-dev libgnomeui-dev libglade2-dev
libgnomeprint2.2-dev

标签:, ,

Your Comments

近期评论

    功能


    网站地图xml地图